Ban Appeals System
Incident Report for AYS Network
Resolved
Our ban appeals system is back up and can be viewed at https://appeals.ays.gg
Posted Sep 30, 2021 - 08:18 UTC
Investigating
Our ban appeals system is currently experiencing issues.
Posted Sep 14, 2021 - 07:33 UTC